edit this page - page history - about editing

Could not open the editor: SAXParserFactoryImpl cannot be cast to SAXParserFactory

Eclipse

Could not open the editor: org.apache.xerces.jaxp.SAXParserFactoryImpl cannot be cast to javax.xml.parsers.SAXParserFactory

This occurs when is more than one SAX parser in your current classpath heirarchy, e.g. the calling plugin requires a SAXParser but one has already been created in another plugin which cannot be accessed through the classpath.

Solution: You may have two Xerces plugins in your environment. Use the Plug-in Registry (Window > Show View > Plug-in Development > Plug-in Registry) to find out which plugins are causing this. In my case, I had two plugins which both contributed a xerces.jar.
Categories: Java | Eclipse | Troubleshooting
edit this page - what links to here? - page history - top
Last edited by jevon jevon 98 months ago